Replaced TCM/valve body now evem worse

Post Reply
Gator417
Regular Member
Posts: 19
Joined: Wed May 31, 2017 12:33 am

Replaced TCM/valve body now evem worse

Post by Gator417 » Tue Oct 30, 2018 3:22 am

Just replaced the TCM with a rather pricey part from ebay. I forgot to disconnect the battery while working. Initially, it went into R with a bang and a lurch and D with same. TC light, wrench light & engine light all on. Disconnected the battery and let it sit for a while. Now when started all the lights come on and the tranny won't go in to any gear. This TCM was supposed to be from an AWD FS, that's why I got this one specifically. Does this sound like it needs to be flashed or do I have a much larger problem? If it needs to be flashed, who can do this?
Thank you,
Gator
'06 AWD SE


ds32928
Regular Member
Posts: 90
Joined: Tue Jan 19, 2010 11:58 am

Re: Replaced TCM/valve body now evem worse

Post by ds32928 » Tue Oct 30, 2018 5:54 am

https://etesupport.zendesk.com/hc/en-us ... nsmission-

Maybe over reaching some in all the steps they want the transmission shop or DIY to follow to get any warranty replacement down the line, they do warn not to operate the vehicle until the flash is done first, with a lengthy description of calibrating the TCM after the flash.

User avatar
jas88
Regular Member
Posts: 601
Joined: Tue Apr 10, 2007 9:48 pm

Re: Replaced TCM/valve body now evem worse

Post by jas88 » Tue Oct 30, 2018 5:56 am

AFAIK it should still go into gear but the lights would be on as described if not flashed.
2006 SE Silver w/Slate cloth

Gator417
Regular Member
Posts: 19
Joined: Wed May 31, 2017 12:33 am

Re: Replaced TCM/valve body now evem worse

Post by Gator417 » Tue Oct 30, 2018 10:16 am

Thanks for the replies.
I'm going to check the plug and make sure its seated properly and then go from there.
Gator
'06 AWD SE

Post Reply