TC Light, CEL, and some grinding

Post Reply
donald402
Regular Member
Posts: 20
Joined: Mon May 23, 2016 8:23 pm

TC Light, CEL, and some grinding

Post by donald402 » Thu Jan 25, 2018 9:04 pm

I've had the TC light on for a bit. reading on here made it sound that nothing would be hurt to drive with the light on for a while. That the only side effect would be no AWD action. I'm waiting for better weather, but may just take it to a Volvo shop I found.

Anyways, it snowed recently and while stuck the wife had the wheels spinning. A check engine light came on and a grinding sound started. Turned off the TC and grind went away. Tried turning the TC back on and grind came back. Got the car home, reset the CEL, and the grind went away when TC is on.

Any ideas as to what's happening?


pmassey31545
Regular Member
Posts: 232
Joined: Sat Feb 18, 2017 7:23 am

Re: TC Light, CEL, and some grinding

Post by pmassey31545 » Fri Jan 26, 2018 7:00 pm

I'm no AWD mechanic and I know this may sound obvious...but sounds like something is wrong with the AWD. HA!!!

That said, I seem to recall people speaking of the 'Haldex' unit and maybe that is your issue. We have an AWD and it has been great. But we went to the mountains about a month ago to see some snow. I pulled off the road and got a little deeper than I wanted and the AWD didn't help at all. It was then that I learned AWD is NOT 4WD!.

Anyway, sounds like it's only grinding when you go into AWD So that to me seems like the rear gears are goofed up... or maybe need to be serviced and lubed.

Search for Haldex in the forum.
2007 Limited AWD
2009 Ford Flex SEL, 2002 F150 Lariat Supercrew, 2005 Kawasaki 1500 Classic, 1999 Toyota Camry

donald402
Regular Member
Posts: 20
Joined: Mon May 23, 2016 8:23 pm

Re: TC Light, CEL, and some grinding

Post by donald402 » Sat Jan 27, 2018 5:40 am

From what I have read, since the TC light is already on, the AWD is already disabled. The grinding was happening while the TC was engaged. But I'm wondering if heavy TC use tries to re-engage the AWD, which isn't working right now.

pmassey31545
Regular Member
Posts: 232
Joined: Sat Feb 18, 2017 7:23 am

Re: TC Light, CEL, and some grinding

Post by pmassey31545 » Sat Jan 27, 2018 5:37 pm

Anytime I turn the TC off, restarting the car re-enables it. That may be an obvious point as well. I don't think it has a time limit that would automatically re-enable it.

Again...my guess is something in the rear drivetrain. Haldex unit being a thought.
2007 Limited AWD
2009 Ford Flex SEL, 2002 F150 Lariat Supercrew, 2005 Kawasaki 1500 Classic, 1999 Toyota Camry

Post Reply