Out of ideas abs tc light on

Post Reply
06fwdfreestyle
New Member
Posts: 4
Joined: Sun Dec 17, 2017 7:13 pm

Out of ideas abs tc light on

Post by 06fwdfreestyle » Sun Dec 17, 2017 7:37 pm

Ok so I got this 06 fwd freestyle I bought with tc and abs lights on. Got it in shop and scanned codes, right rear wheel speed sensor malfunction. So replaced sensor and code remains. Replaced with another new sensor, problem remains. Also after each time the battery has been unhooked for at least 30 minutes sometimes longer. After some research I decided to replace the hub. Did with an aftermarket, still no change. Decided to upgrade to a moog, still no change. When you start vehicle the lights are off, it’s not until you drive about 10’ that the tc and abs light comes on. When sitting with back tires off ground you can see via scanner that the right rear is putting out a signal when wheels are rotated. Also if you are driving down to road and quickly cycle the key off then on again the light will not come back on until you come to a stop and take off again. Also before you stop and lights are still off, you can see via scanner that all 4 wheel speed sensors are working and reading the same speed. Sooo I also decided since there was a code saying something to the effect of abs module communication error( I figured this was on as result of sensor code) to change the abs module out. Did that and it again made no difference and I didn’t want to reflash that module if it wouldn’t fix it. so I put the old one back in. I have also taken the hub from left rear and swapped it with the right rear to see if problem would follow just to rule out hub. It’s as though sensor is not plugged in. Next step I suppose is chasing wiring. Everyone’s post I’ve read they cured their problem with either a new sensor or a new hub. Also my hub mounting surface is spotless clean as is the bore and mounting surface of the wheel speed sensor. Sorry for the novel but just trying to be thorough. Also the tc isn’t working, when lights are off on first startup if you push the tc button the button lights up but the light on the dash won’t come on. Probably related to the wheel speed issue but trying to remember everything I’ve tried. I’m at least lucky to have a parts vehicle to rob parts from


User avatar
jas88
Regular Member
Posts: 601
Joined: Tue Apr 10, 2007 9:48 pm

Re: Out of ideas abs tc light on

Post by jas88 » Mon Dec 18, 2017 6:55 am

I am not sure about the codes, but if you have a mismatch between the ECU and the ABS module WRT the VIN, then those lights will be on. Perhaps the PO swapped out the ABS module already trying to fix the problem and now you have a VIN mismatch?
2006 SE Silver w/Slate cloth

06fwdfreestyle
New Member
Posts: 4
Joined: Sun Dec 17, 2017 7:13 pm

Re: Out of ideas abs tc light on

Post by 06fwdfreestyle » Fri Dec 29, 2017 1:00 pm

I just replaced the ecu and the abs module again. Had dealer reflash ecu and reprogram abs module. No change other than now it says the rcm has an internal fault. So waiting on that part to show up and take it back in. I’m very doubtful that that is the problem but regardless it’s acting up now too

06fwdfreestyle
New Member
Posts: 4
Joined: Sun Dec 17, 2017 7:13 pm

Re: Out of ideas abs tc light on

Post by 06fwdfreestyle » Fri Dec 29, 2017 1:08 pm

Guess I forgot to mention that since my first post we went ahead and had a different abs module put in but dealer couldn’t get it to program so back to salvage yard and got another one. This time dealer got it to program but didn’t change the issue. So they told me it was yet another bad abs module. At this point I’m getting pretty doubtful of them actually diagnosing instead of just throwing money at it. So I have it at a guys shop right now that also has all the ford dealer scan equip. Idk at this point not sure what else to do

06fwdfreestyle
New Member
Posts: 4
Joined: Sun Dec 17, 2017 7:13 pm

Re: Out of ideas abs tc light on

Post by 06fwdfreestyle » Tue Jan 09, 2018 8:34 am

Figured I would post in case some poor sob runs into this same problem. It’s FIXED!! The wiring harness that runs from the rear of car to the abs module, stopping and picking up more wires at the rcm, clips in under dash above steering column. At some point the single push pin that holds this harness in place had let go, letting the harness rest on the metal steering column. Eventually it rubbed a hole through the insulation on one wire. That wire was 1 of 2 that go to the right rear speed sensor. Very simple solution just hard time finding it.

User avatar
mmsstar
Regular Member
Posts: 1098
Joined: Thu Dec 25, 2008 10:44 am

Re: Out of ideas abs tc light on

Post by mmsstar » Tue Jan 09, 2018 9:39 am

Good job and thanks for the explanation!
Drove an 06 LTD FWD from July 08 to August 10, moved on to a 2011 Flex

Post Reply