2007 Freestyle Wrench light questions

Post Reply
AH1976
New Member
Posts: 2
Joined: Mon Jul 10, 2017 4:50 am

2007 Freestyle Wrench light questions

Post by AH1976 » Mon Sep 25, 2017 4:55 am

I have a 2007 Freestyle I purchased used from a Ford dealer May 2016. Love the versatility of this vehicle and really appreciate this website as it's my "go to" to find answers for my shade tree mechanic :D .

So my wrench light went on about a year ago. The next day I took it to a garage by my work and they couldn't find any codes(the light had already gone off upon restart on my way there). They "reset" it and said could have be a freak thing or could happen again. No issues until 2 weeks ago wrench light went on. After sitting and restarting no light. Neither time was there any poor shifting, surging, or lack of power. Fast forward to yesterday light went on again, surged a bit went put in reverse, and had lack of power, but seemed to shift ok. Got to destination about 8 miles up the road and the car sat about and hour and a half the light went off after restart had and no issues. I know there's obviously something wrong that has to be addressed. I've read on this forum and it sounds like it could be the throttle body, PCM, maybe Tranny temp sensor? I logged into the Ford website with my VIN # and see there is a recall for the throttle body. Problem is I'm just a little over 150K and had no idea there was a recall or was notified of one. Any help on what to look for or do would be greatly appreciated since replacing parts on a guess can get expensive and me trading in this vehicle isn't an option financially. Below is what the scenario was the last 2 times the light went on, things I've noticed lately and maintenance I've had done to my Freestyle.

- Last 2 times light went on the car was idling for 10-15 minutes
- AC was on. It's been unseasonably hot here in Central IL
- Both times we had taken long trips(2 round trips in 2 days to Springfield and 2 round trips north of
Pontiac-the son plays travel soccer and we put a ton of miles on some weekends)
- MPG on the message center was at 18.9 put some Lucas cleaner in a few fill ups ago went up to 20.1

Repairs:
- New battery 7/17
- Scroll valve on AC compressor w/ freon 7/17
- Rear brakes, rotors, calipers(caliper sticking on one side) 6/17
- Valve cover gaskets 12/16
- Front brake pads and rotors 11/17
- CVT fluid drain refill 9/16
- Front brake pads 7/16
- Change oil every 3-5k with Mobil 1 Super synthetic 5w/20

Husband is going to check the CVT fluid tonight after work and I'm going to drive our back up vehicle
2000 Volvo S40 which has it's own weird issues :?. Have a Ford dealership about 15 minutes away, but I'm not confident by the posts I've read here and in my experience that the dealerships always have the knowledge on the Freestyle. Our mechanic(retired) is good about making repairs as long as we tell him what to fix. Sorry for the long post, but wanted to give as much info as possible. Any insight would be greatly appreciated!!
2007 Freetsyle SEL, 2000 Volvo S40


User avatar
jas88
Regular Member
Posts: 502
Joined: Tue Apr 10, 2007 9:48 pm

Re: 2007 Freestyle Wrench light questions

Post by jas88 » Mon Sep 25, 2017 6:24 am

First thing I would do is clean the TB. The TB must be removed to do this properly. Use an old toothbrush and a spray cleaner that is made for TB cleaning (so it won't remove the coating). Be sure and disconnect the battery while you are doing this. It is OK to move the throttle blade by hand to aid in cleaning.
2006 SE Silver w/Slate cloth

AH1976
New Member
Posts: 2
Joined: Mon Jul 10, 2017 4:50 am

Re: 2007 Freestyle Wrench light questions

Post by AH1976 » Mon Sep 25, 2017 6:51 am

Ok, thanks we will try that first. Is there a way of testing the PCM and is there a chance this could be the mechatronics unit?
2007 Freetsyle SEL, 2000 Volvo S40

User avatar
Africa_FS_07
Regular Member
Posts: 1607
Joined: Sat Apr 09, 2011 10:57 am
Location: Africa

Re: 2007 Freestyle Wrench light questions

Post by Africa_FS_07 » Mon Sep 25, 2017 9:02 pm

1...how many miles on the car?

2...have you checked the CVT Fluid level at operating conditions (hot) lately ?

3...did you change any/both of the 2 CVT Filters when you did the Drain and Fill ?

4...if YES to 3, can you remember if the old seal on the Pan filter neck came out together with the filter (should come out) before putting in the new Pan Filter ?
i wonder who "Voodoo Bob of the Dead Poets Society" is hounding now.....:mrgreen:

Post Reply