2007 freestar running rough

booner155
New Member
Posts: 1
Joined: Wed May 10, 2017 1:50 pm

2007 freestar running rough

Postby booner155 » Wed May 10, 2017 1:57 pm

last week my freestar started running like shit all of a sudden. it idles rough but consistent and when taken for a drive and kicked down runs rough and takes forever to shift. rmps way higher to initiate a shift than before. im getting a code p0171. which from what i can see can be several causes. my initial thought was plugs or wires. changed the front three but having a hell of a time getting at the back three. the thing that is odd is that it never threatens to stall at all, just runs rough and consistently rough and started all at once. any help from the experts on here would be appreciated as im not keen on paying 129$\]hr at the dealer. heading out now to clean the maf sensor.


Brooklyn_Freestyle
Regular Member
Posts: 43
Joined: Wed Nov 06, 2013 7:32 am
Location: Brooklyn, NY

Re: 2007 freestar running rough

Postby Brooklyn_Freestyle » Wed May 10, 2017 2:01 pm

I'd start by cleaning the throttle body to rule that out. It's easy to do and the cause of many idle problems.
2006 FS SEL AWD w/ 90k miles

User avatar
FordTaurus
Regular Member
Posts: 727
Joined: Mon Jul 10, 2006 9:24 am
Location: N.J.

Re: 2007 freestar running rough

Postby FordTaurus » Wed May 10, 2017 5:04 pm

Freestyle? No?

Brooklyn_Freestyle
Regular Member
Posts: 43
Joined: Wed Nov 06, 2013 7:32 am
Location: Brooklyn, NY

Re: 2007 freestar running rough

Postby Brooklyn_Freestyle » Thu May 11, 2017 10:15 am

FordTaurus wrote:Freestyle? No?

I missed that, just assumed Freestyle.
2006 FS SEL AWD w/ 90k miles


Return to “I just got a Freestyle!”



Who is online

Users browsing this forum: No registered users and 1 guest