2006 Freestyle on trade

Post Reply
kw4tx
New Member
Posts: 3
Joined: Wed Feb 22, 2017 7:36 pm

2006 Freestyle on trade

Post by kw4tx » Wed Feb 22, 2017 7:42 pm

I just traded for a 2006 Freestyle for my wife...

2 issues showing its ugly head...

1 the top motor mount/ cvt torque? makes noise when putting in gear and taking off

2 The darn thing will just shut off, well it will shutter and lose power and the wrench icon will come on have no power... shut it off and on a few minutes later and it is back to normal...

I need to fix this... Anyone know how?

I got a good deal if this is not a major problem.


pmassey31545
Regular Member
Posts: 199
Joined: Sat Feb 18, 2017 7:23 am

Re: 2006 Freestyle on trade

Post by pmassey31545 » Wed Feb 22, 2017 8:36 pm

Haven't had the issue yet. But from what Ive read its your transmission. Park it and get it fixed or you'll completely ruin it if you keep driving. Probably need to change the CVT fluid, high pressure filter and the solenoids.

The mount is simple. But could have led to your trans issue as well.
2007 Limited AWD
2002 F150 Lariat Supercrew, 2005 Kawasaki 1500 Classic, 1999 Toyota Camry

RVAFreestyle
Regular Member
Posts: 160
Joined: Tue Dec 22, 2015 4:09 pm

Re: 2006 Freestyle on trade

Post by RVAFreestyle » Thu Feb 23, 2017 7:44 pm

What does the noise sound like? A clunk going in gear or a whirling helicopter noise in neutral or park?

Have you checked diagnostic codes?
ASE Master Tech L1, X1, A9
ASE Master Collision Repair Technician
ASE Parts & Collision Estimator Certified

2010 Expedition, 2005 Freestyle, 1999 Explorer Sport, 1997 Mustang GT

kw4tx
New Member
Posts: 3
Joined: Wed Feb 22, 2017 7:36 pm

Re: 2006 Freestyle on trade

Post by kw4tx » Fri Feb 24, 2017 12:58 am

noise when putting in gear and on first acceleration...

you press the gas and <clunk>...drives normal.... then every time you start off <clunk>

no codes

RVAFreestyle
Regular Member
Posts: 160
Joined: Tue Dec 22, 2015 4:09 pm

Re: 2006 Freestyle on trade

Post by RVAFreestyle » Sat Feb 25, 2017 3:42 pm

Its likley a bad motor mount. Specifically the torque mount. Pop the hood, back center of engine. Dorman make a replacment bushing kit so you dont have to pay for the entire aluminum cast mount.

Pluse the bushing is easier and quicker to replace
ASE Master Tech L1, X1, A9
ASE Master Collision Repair Technician
ASE Parts & Collision Estimator Certified

2010 Expedition, 2005 Freestyle, 1999 Explorer Sport, 1997 Mustang GT

kw4tx
New Member
Posts: 3
Joined: Wed Feb 22, 2017 7:36 pm

Re: 2006 Freestyle on trade

Post by kw4tx » Mon Feb 27, 2017 7:23 pm

RVAFreestyle wrote:Its likley a bad motor mount. Specifically the torque mount. Pop the hood, back center of engine. Dorman make a replacment bushing kit so you dont have to pay for the entire aluminum cast mount.

Pluse the bushing is easier and quicker to replace

yep...thats it... and it needs a new electronic throttle body threw a P2104 and P2111 code....

gonna cost me $120 to replace torque motor mount..

Post Reply