If you shop at Amazon.com (for anything), use this link to support MyFordFreestyle.com!

One windshield wiper not working

Post Reply
KonaKen
New Member
Posts: 3
Joined: Mon Jan 13, 2020 6:11 am

One windshield wiper not working

Post by KonaKen » Mon Jan 13, 2020 6:15 am

Hi all,

passenger wiper on my 2006 Ltd is not working, any idea what it could be? Apparently there is one motor and one fuse for both wipers. I can turn the wiper by hand, it moves freely, where the driver side does not. All help is appreciated.

Ken

User avatar
jas88
Regular Member
Posts: 701
Joined: Tue Apr 10, 2007 9:48 pm

Re: One windshield wiper not working

Post by jas88 » Mon Jan 13, 2020 8:20 am

Your linkage is broken. Remove the wiper arms and cowl panel between the hood and windshield and you will see it.
2006 SE Silver w/Slate cloth

KonaKen
New Member
Posts: 3
Joined: Mon Jan 13, 2020 6:11 am

Re: One windshield wiper not working

Post by KonaKen » Mon Jan 13, 2020 1:13 pm

thanks for the response jas88!

So, sounds like replacement parts are required. Would it be the entire motor and linkage assembly?
Have you also made a similar repair?

Ken

User avatar
jas88
Regular Member
Posts: 701
Joined: Tue Apr 10, 2007 9:48 pm

Re: One windshield wiper not working

Post by jas88 » Tue Jan 14, 2020 8:44 am

No never had this problem before. IMO you should be able to repair the linkage, but you never know until you find out what exactly broke.
2006 SE Silver w/Slate cloth

User avatar
mmsstar
Regular Member
Posts: 1153
Joined: Thu Dec 25, 2008 10:44 am

Re: One windshield wiper not working

Post by mmsstar » Tue Jan 14, 2020 10:29 am

I’d bet a clip worked loose and it just came apart
Drove an 06 LTD FWD from July 08 to August 10, moved on to a 2011 Flex

brad e
Regular Member
Posts: 32
Joined: Fri Jan 18, 2013 12:54 pm

Re: One windshield wiper not working

Post by brad e » Tue Jan 14, 2020 3:07 pm

Also, check the splines/teeth on the post and arm. There is a chance those splines have stripped and the post is spinning freely inside the arm. If you remove the cap where the arm connects the post at the cowl, you should be able to see if the post is spinning.

KonaKen
New Member
Posts: 3
Joined: Mon Jan 13, 2020 6:11 am

Re: One windshield wiper not working

Post by KonaKen » Fri Jan 17, 2020 6:42 am

had to replace linkage/transmission, couldn't source a bushing. Attached image shows worn/rusted bushing. toughest part was removing seized wiper arms. Cost of linkage $120cdn
IMG_1592.jpg
IMG_1592.jpg (35.44 KiB) Viewed 20 times

Post Reply