If you shop at Amazon.com (for anything), use this link to support MyFordFreestyle.com!

problem starting my 05 freestyle

Post Reply
Deano
New Member
Posts: 6
Joined: Wed Jul 01, 2015 5:47 am

problem starting my 05 freestyle

Post by Deano » Wed Jul 01, 2015 6:13 am

hopefully someone can help, I am having a problem starting the car, I turn the key the dash lights come on but the starter does not engage. I do hear the fuel pump when the key is turned. Sometimes I have to turn the key 20-30 times then it will engage the starter and it turns over and starts no problem. getting very frustrated. Ford did replace the instrument cluster because my gages were dropping out while the car was running but it didn't get rid of the starting problem. Any suggestions will be appreciated. oh it does seem to be worse now the weather is warmer, all winter it seemed to be fine.

Wheelman
Regular Member
Posts: 1632
Joined: Fri May 20, 2005 9:31 am
Location: Yorkton, Saskatchewan Canada

Re: problem starting my 05 freestyle

Post by Wheelman » Wed Jul 01, 2015 8:23 am

!. Check your battery posts. If you see corrosion remove, clean both posts and cable clamps, using water and wire brush. There is acid on them so be careful.
2. Check cable connections on other ends be sure they are tight.
3. Your starter may be bad.
4. Your ignition switch may be bad.
Check in that order cheaper and easier first. Good luck.

Deano
New Member
Posts: 6
Joined: Wed Jul 01, 2015 5:47 am

Re: problem starting my 05 freestyle

Post by Deano » Wed Jul 01, 2015 9:13 am

Thanks for the input I'll check all battery connections and have a mechanic check the starter, then the ignition switch and I'll let you know what it turns out to be. Thanks again!

Deano
New Member
Posts: 6
Joined: Wed Jul 01, 2015 5:47 am

Re: problem starting my 05 freestyle

Post by Deano » Sun Aug 02, 2015 7:13 am

Well problem still there, we have had the starter replaced, the relay, now we think it has something to do with the security. when the car doesn't start the security symbol in the dash lights doesn't come on, it's there every time it does start. The question is what needs to be done to correct this? Could it be the ignition key chip reader that's the problem?

User avatar
Fat Steve
Regular Member
Posts: 356
Joined: Mon Jan 22, 2007 12:44 pm
Location: Round Lake, IL

Re: problem starting my 05 freestyle

Post by Fat Steve » Sun Aug 02, 2015 2:45 pm

Try alternate key. The keys have chips in them and eventually die
Steve
05 Freestyle
03 Mustang GT

Deano
New Member
Posts: 6
Joined: Wed Jul 01, 2015 5:47 am

Re: problem starting my 05 freestyle

Post by Deano » Sun Aug 02, 2015 4:03 pm

We try that every time it doesn't start. it doesn't matter what key we use it wont start until we get the security symbol light on in the dash.

rematar
Regular Member
Posts: 134
Joined: Fri Jun 01, 2012 10:15 am
Location: Edmonton, AB

Re: problem starting my 05 freestyle

Post by rematar » Sun Aug 02, 2015 7:43 pm

I had a similar problem on a 70's GM product. One of the main battery cables was failing inside the sheath. When I wiggled the cable - it would start. Then replaced the cable and it went away.
Yours does sound kind of linked to the security thing though.
2008 Limited AWD (dark ink blue)
2006 Limited AWD (sold)

Deano
New Member
Posts: 6
Joined: Wed Jul 01, 2015 5:47 am

Re: problem starting my 05 freestyle

Post by Deano » Mon Aug 03, 2015 6:10 am

Thanks for the input I'll inspect the cables but I don't think it'll help I've moved them around when it doesn't start. It's going back into the shop Tuesday. hopefully they figure it out from here. I'll let you know what it is.

Post Reply