If you shop at Amazon.com (for anything), use this link to support MyFordFreestyle.com!

Need help! I have the idle issue!!

Post Reply
B3RDii
New Member
Posts: 3
Joined: Wed Apr 23, 2014 2:43 pm

Need help! I have the idle issue!!

Post by B3RDii » Wed Apr 23, 2014 2:55 pm

Ok! so I purchased my freestyle from my father after telling him sense the day he brought it home that I would own it one day. He finally gave it up with a list of things that should be done to it to keep it running like new! so The first thing I did on the list was replace the battery sense it still had the stock battery in the car and was at 143,000 miles! The car ran WONDERFULY until I put this new battery in. On my way home my idle was all over the place trying to die on me and the computer was confused, so my dad told me to let it adjust over the course of a couple days. a couple days later and the idle is ok for the most park but about 60% of the time I come to a stop the idle dips to the point where lights will dim. the idle always corrects itself before it right before it dies! so we did the sparkplugs, I got the PCM calibrated at Korum where the car was purchased and now I just threw a new throttle body in the vehicle and it still wont stop dropping! I have also noticed in the morning the idle is indeed lower then when I drive home after work (if this helps at all). I don't want to sell it because I love the vehicle but This is driving me mad and I have already pissed away over 1000 dollars trying to fix it!!! if anyone has had this problem please help!! its not like I haven't taken it to see a mechanic! it has seen 3 now, but I have NO check engine light which is odd because the car comes close to dying every other time I come to a stop! and one more thing when it get warmer and driven farther distances the rpms will drop before I come to a complete stop and before it dies the idle will fly up to almost over 1000 Rpms causing me to surge forward!! like I said lol PLEASE HELP!!

User avatar
CARR142
Regular Member
Posts: 114
Joined: Wed Feb 14, 2007 3:37 pm
Location: CHERRY HILL, NEW JERSEY
Contact:

Re: Need help! I have the idle issue!!

Post by CARR142 » Wed Apr 23, 2014 4:55 pm

There is learning procedure for this. When and if I find this I will send it to you.
" I got the PCM calibrated at Korum"
This may be the same as the procedure I am referring too.

B3RDii
New Member
Posts: 3
Joined: Wed Apr 23, 2014 2:43 pm

Re: Need help! I have the idle issue!!

Post by B3RDii » Wed Apr 23, 2014 7:04 pm

thank you! I followed the procedure in the Freestyle handbook multiple times and like I said Korum updated my PCM to all the "latest calibrations" but anything helps!!

User avatar
Africa_FS_07
Regular Member
Posts: 1657
Joined: Sat Apr 09, 2011 10:57 am
Location: Africa

Re: Need help! I have the idle issue!!

Post by Africa_FS_07 » Sat May 03, 2014 4:52 pm

B3RDii wrote:Ok! so I purchased my freestyle from my father after telling him sense the day he brought it home that I would own it one day. He finally gave it up with a list of things that should be done to it to keep it running like new! so The first thing I did on the list was replace the battery sense it still had the stock battery in the car and was at 143,000 miles! The car ran WONDERFULY until I put this new battery in. On my way home my idle was all over the place trying to die on me and the computer was confused, so my dad told me to let it adjust over the course of a couple days. a couple days later and the idle is ok for the most park but about 60% of the time I come to a stop the idle dips to the point where lights will dim. the idle always corrects itself before it right before it dies! so we did the sparkplugs, I got the PCM calibrated at Korum where the car was purchased and now I just threw a new throttle body in the vehicle and it still wont stop dropping! I have also noticed in the morning the idle is indeed lower then when I drive home after work (if this helps at all). I don't want to sell it because I love the vehicle but This is driving me mad and I have already pissed away over 1000 dollars trying to fix it!!! if anyone has had this problem please help!! its not like I haven't taken it to see a mechanic! it has seen 3 now, but I have NO check engine light which is odd because the car comes close to dying every other time I come to a stop! and one more thing when it get warmer and driven farther distances the rpms will drop before I come to a complete stop and before it dies the idle will fly up to almost over 1000 Rpms causing me to surge forward!! like I said lol PLEASE HELP!!
hi,

i don't know if this would be useful but while it isn't the same type of car, this unstable RPM behavior at idle or stop is very much consistent with a very dirty or faulty Idle Air Control Valve (IACV) in Hondas.....Air issues.

while it was usually possible to fix the IACV issue with a good cleaning (they get clogged with a lot of dust), in the one that i used to own, i had to eventually change the IACV to get rid of the issue....fortunately in the Hondas, these IACV would spit out a code pointing you in its direction, unfortunately your car has not thrown a code to show what's responsible.

in the Honda Accord i'm referring to, the IACVs are mounted on the side of the T.B.

i don't know if the Freestyle incorporates an IACV right on the T.B....as matter of fact, i can't remember seeing anything which looks like an IACV on the Freestyle T.B. whenever i cleaned the T.B. in the past.......i don't know if the Freestyle even uses an IACV.

can you try to check if they used an IACV in the Freestyles or replaced it with something else and look into that?
Last edited by Africa_FS_07 on Sun May 04, 2014 1:16 am, edited 2 times in total.
i wonder who "Voodoo Bob of the Dead Poets Society" is hounding now.....:mrgreen:

B3RDii
New Member
Posts: 3
Joined: Wed Apr 23, 2014 2:43 pm

Re: Need help! I have the idle issue!!

Post by B3RDii » Sat May 03, 2014 4:58 pm

My IAC is built into my throttle body so it got a brand new one when I replaced my throttle body, so I'm swapping out the pcm this week l. Korum thinks a part of it might have gotten fried in the battery swap so fingers crossed!! But thank you for the response!

Post Reply