Page 1 of 1

Bad Cluster or Speed Sensor Issue ?

Posted: Wed Feb 06, 2019 8:24 am
by Scotty17
05 SEL AWD

I am having a ongoing issue in which the speedo sometime stops at 30 MPH when traveling up to highway speeds. I notice that sometimes if I slow down for traffic and then resume highway speed the problem goes away.

I am wondering if anyone has this some issue and is it a Cluster issue or a speed senor issue. When the problem happens the shifting from the transmission seems to be shifting ok.

Your thoughts

Thanks

Re: Bad Cluster or Speed Sensor Issue ?

Posted: Sun Feb 10, 2019 6:50 am
by RVAFreestyle
Any warning lamps on? Did you check DTCs?

If there are no DTCs and no warning lamps on for anything else. I would suggest using a good scan tool and monitoring TCM and ABS signals to compare the vehicle speed sensors in both systems. If all looks good, it might be the small stepper motor in the cluster has gone bad. a reputable electronics repair shop can diagnosis and repair the cluster. Try this local shop I use- but they perform work nationally for hard to fix clusters:
https://www.instrumentclusters.com/why-southern

Re: Bad Cluster or Speed Sensor Issue ?

Posted: Sun Feb 10, 2019 11:42 am
by Scotty17
Thanks RVAfreestyle for the info really appreciate it.

Re: Bad Cluster or Speed Sensor Issue ?

Posted: Fri Mar 01, 2019 1:58 pm
by Scotty17
This morning the speedo when stopped in traffic got stuck at 40 MPH and when traveling at highway speed it showed I was doing 85 MPH, got to work turned of the car and speedo was stuck at 40 MPH.

I went into the cluster engineering mode and did a gauge test all of the gauges did a sweep this seem to have corrected the stuck speedo for now.

Still don't know why this issues happens once and a while, you would think if it was a bad cluster it would happen all the time.

Could it be another sensor causing this issue that might be going ?

Re: Bad Cluster or Speed Sensor Issue ?

Posted: Fri Mar 15, 2019 7:41 am
by Scotty17
05 SEL AWD

As is turns out I have a bad cluster found a place online that's been around for many years
that specialize in Cluster repair sending it off next week they run complete tests on the cluster
repair and shipping both way for $235.00

https://www.instrumentclusters.com