If you shop at Amazon.com (for anything), use this link to support MyFordFreestyle.com!

EGR VALVE Question

Post Reply
Mehle90
Regular Member
Posts: 13
Joined: Sun Feb 11, 2018 7:25 pm

EGR VALVE Question

Post by Mehle90 » Sun May 06, 2018 9:32 pm

Hey guys. Couple questions I did my valve cover gasket. Long story car was running perfect besides me being super tired and not tightening a bolt all the way, I fixed the oil from leaking (Thank god) anyways I told off the manifold to get back too the rear valve cover to tighten all the bolts properly. Reinstalled everything and the car is running very rough. I have been doing research and what I believe I might be would be the egr valve, possibly closed, had the car running and heard some popping and other noises really freaked me out. I don't know if I messed something up while being in there hopefully it's just a simple fix. Thanks! Also wanted to note, this probably sounds dumb I had sprayed some starting fluid in the claw of the egr valve not sure if that would irritate it. After doing that it has been running weird. Sprayed starting fluid in there to help with cleaning it

Warbird5
Regular Member
Posts: 18
Joined: Mon Jul 20, 2015 3:14 pm

Re: EGR VALVE Question

Post by Warbird5 » Fri Mar 29, 2019 11:11 am

Morning,

I recently had to replace the EGR valve on my 05 as it was throwing a high resistance code that caused the check engine light to illuminate.

As you know the EGR valve mounts to the intake manifold and has vacuum, electrical connections that must be removed to change the valve or to remove the intake manifold. When changing the valve you have to unbolt the intake manifold.

I'd first check to see if you have disturbed any of the a fore mentioned connections, especially the one that slides on the EGR valve nipple and is secured with a plastic clip. If you have access to a OBD scanner I'd scan for codes. I'd also recheck that the intake manifold is completely installed and the seals are intact, bit cut of dislodged.

Work safe.

fuxxy
Regular Member
Posts: 41
Joined: Sun Aug 10, 2008 3:13 pm

Re: EGR VALVE Question

Post by fuxxy » Mon Jul 29, 2019 2:37 pm

EGR valve not operating correctly will throw a check engine light, with an associated code. If you are not getting any codes from the ECU, you may have accidently disconnected a coil pack or injector.

I would test, with the engine running at idle, by unplugging each injector in sequence and see if one does not affect engine operation. That cylinder is the one not firing, and the culprit for the rough idle.

Post Reply