If you shop at Amazon.com (for anything), use this link to support MyFordFreestyle.com!

Wrench Light!

LimitedX
Regular Member
Posts: 44
Joined: Mon Mar 18, 2013 8:11 am

Re: Wrench Light!

Post by LimitedX » Fri Oct 18, 2019 8:20 am

Hi all,

A quick update. Wrench Light came on again this week, just once. Since the initial error, I have invested in the Blue Driver scan reader - figuring that way I could capture things as they happen and just store the code reader in the car. And - I got a code. TSS Sensor No Signal. Shut off, let rest a bit, turn on, no wrench light. I cleared all the codes - and will continue to drive until I get a confirmation that it is, in fact, a TSS sensor failure. If so, I will probably tackle the TSS repair over a weekend, and while the transmission is open go ahead and replace the OSS too. Will use Motorcraft parts (why cheap out on parts if I'm doing all the labor myself, right)?

In researching the TSS code, I have fond that it is a very common failure, and in the Edge (same transmission and drivetrain) it can happen in the neighborhood of 160,000 miles. Well I'm in that neighborhood. I have the mechanical skills to do this, but it is going to take awhile, so if it throws the same code again then I will tackle it over a weekend.

As for the throttle body, that's on my list to look at as well. I don't have other throttle body symptoms (rough idle, or idle high or low) - although I think the TSS sensor code is giving me a better hint at what is wrong at this point.

Since the initial light, to this light, took about 3 months to light up again, I figure I might be in for another wait before I get a confirmation. Its just such a big job to do... so I'm slow-playing it.

But sooner or later that TSS sensor will fully fail, and not restart by cycling the key. Or that's what I expect....

Very helpful everyone - and my hope is renewed to get 200,000 miles out of this vehicle...

Post Reply