If you shop at Amazon.com (for anything), use this link to support MyFordFreestyle.com!

Security dash light and engine stops

Post Reply
Heffnerpf
New Member
Posts: 3
Joined: Sun Aug 04, 2019 11:45 am

Security dash light and engine stops

Post by Heffnerpf » Sun Aug 04, 2019 12:10 pm

2007 200k recently replaced spark plugs cuz of cyl. 2 misfire code. So had to r&r the intake manifold so had to unhook manifold from egr valve. Cudnt remove egr valve from exhaust tube so left it. All kinds of vac lines and electrical to manifold, and even Fuel line. Replaced pvc. Cleaned throttle body. Etc. etc. Soooo I put everything back. Drove it. Perfect. Then in days following it starts intermittent events with security light on dash: quick flash with engine hiccup, no codes. Worst case is stopping for a light and at start up the sec. light comes on solid and engine stops. It Starts back easily and away I go. Still no codes. Any ideas? My wife is afraid to drive it now.

ds32928
Regular Member
Posts: 152
Joined: Tue Jan 19, 2010 11:58 am

Re: Security dash light and engine stops

Post by ds32928 » Sun Aug 04, 2019 4:00 pm

It happens with either key? If so, I would clean the battery ground to chassis connection. You will have to relearn the ECU after having the ground off long enough to clean it to bare metal.

Heffnerpf
New Member
Posts: 3
Joined: Sun Aug 04, 2019 11:45 am

Re: Security dash light and engine stops

Post by Heffnerpf » Sun Aug 04, 2019 4:19 pm

yes, it happens with either key.

Heffnerpf
New Member
Posts: 3
Joined: Sun Aug 04, 2019 11:45 am

Re: Security dash light and engine stops

Post by Heffnerpf » Tue Aug 06, 2019 5:07 am

I appreciate the interest, and am intrigued at the idea of an electrical issue. That common ground idea confuses me, though. So I could get lots of power for everything else but still have an issue in continuity when riding along?

ds32928
Regular Member
Posts: 152
Joined: Tue Jan 19, 2010 11:58 am

Re: Security dash light and engine stops

Post by ds32928 » Tue Aug 06, 2019 5:55 am

I deleted long post here that might not be on the right track. PATS flashing may just be when engine shuts off and back on, > engine hiccup.
Ignition switch bad? Doubt that a bad switch would throw a code, but cause the loss of spark. Hard problem to diagnose from a distance.

Post Reply