Search found 30 matches

by Stangyog
Mon May 21, 2018 2:23 pm
Forum: Interior & Electronics
Topic: Radio resetting on my '06 Freestyle
Replies: 2
Views: 105

Radio resetting on my '06 Freestyle

The radio started resetting on my '06 Freestyle. Seems to have no real ryme or reason to it. Usually when the car sits for a while. I'll come out to it and the clock has been reset among with all the other settings. But it has also done it while driving down the road. I cleaned the battery terminals...
by Stangyog
Sat Mar 17, 2018 6:09 pm
Forum: General Topics
Topic: Great little OBDII Scanner...
Replies: 0
Views: 133

Great little OBDII Scanner...

Just to put it out there, I got a Foxwell NT630 PRO from Amazon for $140.00 Works very well. Does the usual code scanning stuff, but also has ABS, SRS, and steering wheel alignment functions. I got it to work on my GMC Envoy, but tried it out on my wife's 06' Freestyle. ABS will autobleed ABS system...
by Stangyog
Sun Feb 18, 2018 12:36 pm
Forum: Drivetrain
Topic: CVT Issue When Cold
Replies: 19
Views: 577

Re: CVT Issue When Cold

Glad you got it out. Be sure to use a little anti-seize.
by Stangyog
Wed Feb 14, 2018 2:14 pm
Forum: Drivetrain
Topic: CVT Issue When Cold
Replies: 19
Views: 577

Re: CVT Issue When Cold

If you can get the head off, you may be able to grab the bolt with pliers after you get the filter housing off.
by Stangyog
Tue Feb 13, 2018 6:08 pm
Forum: Drivetrain
Topic: What happens after CVT failure?
Replies: 10
Views: 483

Re: What happens after CVT failure?

Glad you got if fixed, but $400 to change the belt and tensioner!!! That's why I try to do most of the work myself, or worst case, take it to a local shop. The parts probably only cost $50-75.
by Stangyog
Tue Feb 13, 2018 5:59 pm
Forum: Drivetrain
Topic: CVT Issue When Cold
Replies: 19
Views: 577

Re: CVT Issue When Cold

Stangyog wrote:
Tue Feb 13, 2018 5:56 pm
Only real option I see is to drill a hole in the bolt and try an extractor. I'd start small and go bigger if you have to. Was having the same issue with mine the 1st winter I had it (2 years ago), changed both filters, and replaced the fluid and problem solved. I used the Ford CVT Fluid though.
by Stangyog
Tue Feb 13, 2018 5:56 pm
Forum: Drivetrain
Topic: CVT Issue When Cold
Replies: 19
Views: 577

Re: CVT Issue When Cold

Only real option I see is to drill a hole in the bolt and try an extractor. I'd start small and go bigger if you have to.
by Stangyog
Sun Nov 12, 2017 2:09 pm
Forum: Drivetrain
Topic: Cold, car doesn't move? Tranny problem? Wrench error light? Low pressure? P0868? This could save your car.
Replies: 2
Views: 441

Re: Cold, car doesn't move? Tranny problem? Wrench error light? Low pressure? P0868? This could save your car.

I did mine a year ago. Plan on changing it again in the spring... barring any unforeseen problems.
by Stangyog
Tue Jun 27, 2017 5:10 pm
Forum: General Topics
Topic: Trailer Wiring
Replies: 4
Views: 285

Re: Trailer Wiring

Looks like the one on mine! Just plug the connectors in-line with the tail light harness at each taillight. Way easier than trying to splice into wires to get trailer lights. Side note... I tow an almost 800 lbs. trailer with mine, loaded down about 1600-1800 lbs., gross. No issues on short trips. I...
by Stangyog
Tue Jun 27, 2017 5:05 pm
Forum: Drivetrain
Topic: CVT HAS NO MOVEMENT
Replies: 15
Views: 853

CVT HAS NO MOVEMENT

Update... Have had no issues since I replaced the pan filter with an OEM one. Did a fluid only change the other day. Fluid wasn't too bad, plan on changing high pressure one next spring. Should be about 20,000 miles on it by then. Also, still love the car, other than transmission pan filter issue, v...
by Stangyog
Thu Mar 23, 2017 5:14 pm
Forum: Drivetrain
Topic: CVT HAS NO MOVEMENT
Replies: 15
Views: 853

Re: CVT HAS NO MOVEMENT

Yes, Ford filter was different. The seal is bonded to the top of the filter neck. The seal on the aftermarket one would just slide right off the neck.
by Stangyog
Tue Mar 21, 2017 5:32 pm
Forum: Drivetrain
Topic: CVT HAS NO MOVEMENT
Replies: 15
Views: 853

Re: CVT HAS NO MOVEMENT

Update... I replaced the pan filter about 2000 miles ago, and the car seems OK since. Took a 500 mile day trip the other day and had no issues. Going to do another fluid change in a month or so, just because the original fluid looked pretty old when I changed it originally.
by Stangyog
Sun Feb 12, 2017 5:23 pm
Forum: Drivetrain
Topic: CFT30 Trouble Shooting
Replies: 1
Views: 196

CFT30 Trouble Shooting

Found this web site that has some interesting trouble shooting info for the CFT30... may be already on here somewhere, but here it is anyway.

https://www.yumpu.com/en/document/view/ ... ngines/145
by Stangyog
Sat Jan 21, 2017 2:32 pm
Forum: Drivetrain
Topic: CVT Removal... how difficult to do at home
Replies: 14
Views: 967

CVT Removal... how difficult to do at home

Thinking about pulling the tranny to check the input shaft seals. Feels like the touque convertor is not going into lockup. I am a pretty good "Home Mechanic", but would like to have a better idea about what I am getting into. Some instructions, and/or pics would be AWESOME!!! Also, I don't have any...
by Stangyog
Sat Jan 21, 2017 2:30 pm
Forum: Drivetrain
Topic: CVT HAS NO MOVEMENT
Replies: 15
Views: 853

Re: CVT HAS NO MOVEMENT

Filter replaced... still having issues though. Car runs better now, no codes, but I think the torque converter is not locking up. Thinking about pulling the tranny to check the input shaft seals. I am a pretty good "Home Mechanic", but would like to have a better idea about what I am getting into. S...