Search found 43 matches

by dca
Sun Aug 27, 2017 5:40 am
Forum: Drivetrain
Topic: Traction Control light Prbl
Replies: 21
Views: 11127

Re: Traction Control light Prbl

Hey, Kline - There is a process in the TSB where you go from 0 to full throttle a few times after sensor change. The light also probably gets remembered like other trouble lights. I remember also disconnecting battery to reset things. I'll have to dig up the TSB number if you haven't seen it. I have...
by dca
Tue May 30, 2017 10:07 am
Forum: Drivetrain
Topic: "AWD Malfunction" in message center
Replies: 101
Views: 36512

Re: "AWD Malfunction" in message center

found my shop copy and took pictures and sent to you.. good luck
by dca
Tue May 30, 2017 9:43 am
Forum: Drivetrain
Topic: "AWD Malfunction" in message center
Replies: 101
Views: 36512

Re: "AWD Malfunction" in message center

the Haldex drain plug is higher than filter... can't fill through the filter. I believe it's the more forward of the two steel plugs referred to above by Mike is the one you want. It's NOT the soft brass Torx head...I had a transmission mechanic think it was that one and strip it out. I have not fou...
by dca
Tue May 30, 2017 3:31 am
Forum: Drivetrain
Topic: "AWD Malfunction" in message center
Replies: 101
Views: 36512

Re: "AWD Malfunction" in message center

I can send you the procedure doc with pictures for changing all fluids. Jack Watts is there other one who knows a lot about it. PM me your email and I can forward it to you. To answer your immediate question, the fluid goes in the same plug hole that it is siphoned out of, after getting as much flui...
by dca
Tue Apr 30, 2013 4:00 am
Forum: Drivetrain
Topic: "AWD Malfunction" in message center
Replies: 101
Views: 36512

Re: "AWD Malfunction" in message center

Joenyansah, I would think it comes already programmed for your vehicle, assuming you got one made for your vehicle. I was able to get away with fluid/filter, then press/temp sensor change. Pump and DEM were good. My DEM was giving the P1889 code, but the standard code readers & s/w won't read it. I ...
by dca
Sat Jan 12, 2013 7:41 pm
Forum: Drivetrain
Topic: 2007 w/ code P1889
Replies: 16
Views: 5936

Re: 2007 w/ code P1889

Thanks for the info...I went ahead and changed the sensor and gaskets, sincr I heard and felt the AWD engage when the 4x4 module P1889 code was cleared and computer reset. Seems to have fixed it (knocking on wood). You need to follow the TSB (mostly)...they say to put the sensor and solenoid in the ...
by dca
Tue Jan 08, 2013 2:36 pm
Forum: Drivetrain
Topic: 2007 w/ code P1889
Replies: 16
Views: 5936

Re: 2007 w/ code P1889

I am finally revisiting this after nearly 2 yrs of seeing that traction light. Already had fluids changed about 1.5 yrs ago (and it was ugly @ 70k mi). After I finished building my OBD-II scanner (w/CAN bus capability for these vehicles) I realized I needed the $200 software to query the 4x4 module ...
by dca
Tue Apr 17, 2012 8:56 am
Forum: Drivetrain
Topic: TC & ABS lights came on.....
Replies: 16
Views: 1812

Re: TC & ABS lights came on.....

Thought I would hop on this post, since it is still warm (~1 month old)... Jack - I sent you a PM for more info on the OBD diagnostics and Traction / ABS related issues. I need PIDs or recommended S/W, references, etc. I am getting back to finishing the diag for my FS related to this now. gcp - I do...
by dca
Wed Sep 14, 2011 4:51 pm
Forum: Drivetrain
Topic: "AWD Malfunction" in message center
Replies: 101
Views: 36512

Re: "AWD Malfunction" in message center

brendabyrg, After reading these posts, it seems that the pump can be run using +12V while in the Haldex. Although, I am suprised about the lack of attention to polarity. You say you get 1A, then it 'dies out'? What do you mean - it stops drawing current? If so, sounds like the pump is intermittent o...
by dca
Fri Sep 02, 2011 10:14 am
Forum: Drivetrain
Topic: Recommended mechanic says no need to change trans fluid?
Replies: 13
Views: 824

Re: Recommended mechanic says no need to change trans fluid?

I know it sounds stupid, but make sure they know you are talking about the High Pressure media filter and not the screen filter in the pan. I could not find the procedure for the HP filter change in the Ford service manuals. Jack's info is much more detailed than Ford's.
by dca
Thu Aug 18, 2011 10:10 am
Forum: General Topics
Topic: What did you do to your FS today?
Replies: 19
Views: 1488

Re: What did you do to your FS today?

Added Exhaust Tips... They make those MiniVan owners look even more lame compared to our 'Style. Hard to find a clamp on Stainless Steel tips that fit 2-1/4" pipes. Found these from http://3aracing.com/ and they look great (also got 20% off at Advance Auto w/code)! I can't find the MPN right now, an...
by dca
Mon Aug 01, 2011 7:49 pm
Forum: Performance
Topic: Third set of Tires
Replies: 21
Views: 4727

Re: Third set of Tires

When I got my FS, they had just replaced the tires with "Conti's", which seem to be the stock OEM tire. They ride fine now, but they are still nearly brand new. I only use Michelin as replacements. I've wasted time and money, and had serious performance issues with Goodyear and BFG tires. Michelins ...
by dca
Fri Jul 29, 2011 4:18 pm
Forum: Drivetrain
Topic: Uncommanded accelerations
Replies: 3
Views: 442

Re: Uncommanded accelerations

I like the term "uncommanded accelerations" vs. "lunging" (or "surging" or "lurching") :-p Maybe you should work for Ford...hahaha I have only noticed mild increases in acceleration when going into gear so far, and only with A/C on. Probably depends on condition of throttle body. I have been loosely...
by dca
Wed Jun 01, 2011 9:41 am
Forum: Interior & Electronics
Topic: Radio Question
Replies: 2
Views: 554

Re: Radio Question

meyersd: First, I did not know about these devices, but wanted to do the same type of thing. Thanks for sharing the mfg and P/N. W.R.T. your question, according to http://www.pie.net : PIE FRD04-AUX is "Not compatible with factory RSE (Rear Seat Entertainment) present." If you have an iPod, looks li...
by dca
Wed Jun 01, 2011 9:33 am
Forum: Drivetrain
Topic: CVT issues?
Replies: 6
Views: 1181

Re: CVT issues?

mointainfreestyleb - First of all, I would get another shop to work on your FS, since your Ford dealer seems to be ripping you off. Over $1000 everytime you go there is a red flag. Hard to believe 3 consecutive repairs in 4mos each cost that much. Even if the repairs did legitimately cost that much,...